Quantcast
RWD - electrical problems in dash cluster

Volvo RWD 200 Forum

INDEX FOR 12/2018(CURRENT) INDEX FOR 5/2006 200 INDEX [<<]  [>>]

 VIEW    REPLY TO THIS MESSAGE    PRINT   SAVE   A    A 

electrical problems in dash cluster 200 1989

Hey everybody! Just joined the club yet I've been here many times reading others questions and solutions. I've looked for the question that I'm going to ask and haven't found the exact same problem posted. I have an 89 245 it has over 500,000 on it now and has been my truck(overload coils on the back) for almost 20 years. As long as I've had it it's had this gremlin, I start it, start driving, look at the dash and realize that the speedo, gas gauge and charging system aren't working. Somehow I figured out that by simply turning off and then back on the lights that the above will all start working again!! So I've been doing this for 19 years and it's always worked so why mess with it, well it doesn't work any more. Sometimes when I start it everything is fine yet sometimes not and I haven't been able to drive it because of the non charging. Has anybody else ever heard of or had this problem and figured it out?

Thanks in advance!

 





[about brickboard ads]

THREADED THREADED EXPANDED FLAT PRINT ALL
MESSAGES IN THIS THREAD

New 1 electrical problems in dash cluster [200][1989]
posted by  upsidedown  on Tue Dec 4 22:08 CST 2018 >

[about brickboard ads]

Cut and paste link:

<< < > >>


Users marked in green are currently online.

©Jarrod Stenberg 1997-2016. All material except where indicated.


Brickboard.com is not affiliated with nor sponsored by AB Volvo, Volvo Car Corporation, Volvo Cars of North America, Inc. Brickboard.com is a Volvo owner/enthusiast site, similar to a club, and does not intend to pose as an official Volvo site. The official Volvo site can be found here.

All participants agree to these terms.
Powered by Denizen - Custom Software for Enthusiasts