Quantcast
AWD - 2004 XC70 MAF sensor reading Problems? Fluctuating Idle

Volvo AWD V70-XC70 Forum

INDEX FOR 5/2019(CURRENT) INDEX FOR 8/2004 V70-XC70 INDEX [<<]  [>>]

 VIEW    REPLY TO THIS MESSAGE    PRINT   SAVE   A    A 

2004 XC70 MAF sensor reading Problems? Fluctuating Idle V70-XC70

Hello,

My 2004 XC70 is having fluctuating idle speed (500-1200)/stalling at idle problems. It runs great except at idle.

I have the following codes

P2188 -system too rich
261A - long term trim
262A - long term trim

The throttle body is clean and smoke test showed no vacuum leaks. The spark plugs, coils, filters, etc are new or fairly new.
I checked the signal from the MAF which showed fairly steady 1.58-1.6v at idle (cold), 1.16-1.18v idle (warm). If I accelerate slowly the reading is goes to 2.4v at 2000rpm, 3.2v at 3000rpm. If I accelerate quickly the voltage goes to 0 when I open the throttle, then recovers to shown readings. The car accelerates strongly, no hesitation.

Is this normal for the MAF?

Oddly enough, if I unplug the MAF, I get CEL and code for the MAF but the car idles perfectly smooth, no stalls, runs great. When I plug it back in, it goes back to fluctuating and stalling.

Ideas? Thanks, Jim






THREADED THREADED EXPANDED FLAT PRINT ALL
MESSAGES IN THIS THREAD

New 2004 XC70 MAF sensor reading Problems? Fluctuating Idle [V70-XC70]
posted by  someone claiming to be Build  on Sat Mar 9 18:11 CST 2019 >

Cut and paste link:

<< < > >>


Users marked in green are currently online.

©Jarrod Stenberg 1997-2016. All material except where indicated.


Brickboard.com is not affiliated with nor sponsored by AB Volvo, Volvo Car Corporation, Volvo Cars of North America, Inc. Brickboard.com is a Volvo owner/enthusiast site, similar to a club, and does not intend to pose as an official Volvo site. The official Volvo site can be found here.

All participants agree to these terms.
Powered by Denizen - Custom Software for Enthusiasts