Quantcast
RWD - No bottom row ignition lights on start up

Volvo RWD 900 Forum

INDEX 900 INDEX [<<]  [>>]

 VIEW    REPLY TO THIS MESSAGE    PRINT   SAVE   A    A 

No bottom row ignition lights on start up 900 1992

Need to dismantle instrument panel out and look at group of connectors behind it. The connectors are labelled A to E and L.

When all gauges are ok means power and ground are good which comes thru D connector (4 wires) along with speedo input from differential. The lower group of lights are also powered thru D connector but grounded individually according to its purpose thru B and C connectors. So check B and C connectors for looseness/corrosion etc.

If B and C connectors are ok but still no light then you have to check those solder points on the flexible circuit board itself. Location of these points are not shown in circuit diagram. Need to do visual inspection and reflow where necessary. Extra precaution when reflowing those points. Just touch them with soldering iron not more than 1 second to avoid melting the surrounding flexible board.

Hope these help,
Amarin.






THREADED THREADED EXPANDED FLAT PRINT ALL
MESSAGES IN THIS THREAD

New No bottom row ignition lights on start up [900][1992]
posted by  someone claiming to be Tim  on Thu May 9 11:33 CST 2019 >

Cut and paste link:

<< < > >>


Users marked in green are currently online.

©Jarrod Stenberg 1997-2016. All material except where indicated.


Brickboard.com is not affiliated with nor sponsored by AB Volvo, Volvo Car Corporation, Volvo Cars of North America, Inc. Brickboard.com is a Volvo owner/enthusiast site, similar to a club, and does not intend to pose as an official Volvo site. The official Volvo site can be found here.

All participants agree to these terms.
Powered by Denizen - Custom Software for Enthusiasts