Quantcast
RWD - Another Seemingly Mysterious Issue w/My 1993 Volvo 940 Wagon

Volvo RWD 900 Forum

INDEX FOR 6/2019(CURRENT) INDEX FOR 12/2003 900 INDEX [<<]  [>>]

 VIEW    REPLY TO THIS MESSAGE    PRINT   SAVE   A    A 

Another Seemingly Mysterious Issue w/My 1993 Volvo 940 Wagon 900

Try cleaning the wire posts at battery and starter. Disconnect and wire brush the connections. At the starter solenoid, the top wire is to battery, middle to ignition switch and bottom to starter motor. Clean the bottom post too. This has always been overlooked during starter maintenance. Also include cleaning the main chassis ground wire near the battery.

If you suspect failing battery test by turning on the headlights (ignition key at KPII) after doing the above. Alternatively a carbon pile tester is needed to test battery.

Amarin.






THREADED THREADED EXPANDED FLAT PRINT ALL
MESSAGES IN THIS THREAD

New Another Seemingly Mysterious Issue w/My 1993 Volvo 940 Wagon [900]
posted by  onlyVolvo  on Sun May 5 14:41 CST 2019 >

Cut and paste link:

<< < > >>


Users marked in green are currently online.

©Jarrod Stenberg 1997-2016. All material except where indicated.


Brickboard.com is not affiliated with nor sponsored by AB Volvo, Volvo Car Corporation, Volvo Cars of North America, Inc. Brickboard.com is a Volvo owner/enthusiast site, similar to a club, and does not intend to pose as an official Volvo site. The official Volvo site can be found here.

All participants agree to these terms.
Powered by Denizen - Custom Software for Enthusiasts