Quantcast
RWD - 940 runnin' bad

Volvo RWD 900 Forum

INDEX FOR 9/2019(CURRENT) INDEX FOR 8/2019 900 INDEX [<<]  [>>]

 VIEW    REPLY TO THIS MESSAGE    PRINT   SAVE   A    A 

940 runnin' bad 900 1991

Hi all, thanks for reading this.
Problem:
1. hesitation on acceleration and cruising. Not all the time, seems to get worse after car is fully warmed up. Seems to be a little worse when gas is low (1/8 tank).

2. Idle has always seemed a little coarse, car vibrates a bit. Lately it will idle low, sometimes stall, then idle high. (by the way my tach is not accurate)

stuff i've tried:
throttle body cleaning.
new cap, rotor, plugs, motor and trans mounts.
installed used IAC

The IAC i took out had a stuck gate, i wonder if maybe I'm not getting proper voltage there.
I bought the car used. It appears to have been repainted and there's some bondo on a rear quarter.

Any help is greatly appreciated.

-Sabadooski






THREADED THREADED EXPANDED FLAT PRINT ALL
MESSAGES IN THIS THREAD

New 940 runnin' bad [900][1991]
posted by  sabadooski  on Fri Sep 22 19:55 CST 2006 >

Cut and paste link:

<< < > >>


Users marked in green are currently online.

©Jarrod Stenberg 1997-2016. All material except where indicated.


Brickboard.com is not affiliated with nor sponsored by AB Volvo, Volvo Car Corporation, Volvo Cars of North America, Inc. Brickboard.com is a Volvo owner/enthusiast site, similar to a club, and does not intend to pose as an official Volvo site. The official Volvo site can be found here.

All participants agree to these terms.
Powered by Denizen - Custom Software for Enthusiasts