Quantcast
RWD - Instrument Cluster and Rear Lights Not Working. 94 940 Wagon

Volvo RWD 900 Forum

The message to which you are about to reply is shown first. GO TO REPLY FORM



 VIEW    REPLY TO THIS MESSAGE    PRINT   SAVE   A    A 

Instrument Cluster and Rear Lights Not Working. 94 940 Wagon 900

Hi All,
My wife's 94 940 wagon is having light problems.

The instrument cluster and rear lights are not working.

The instrument lights and tail lights only come on when the parking lights are on, ie 12'oclock position on the light dial. When dial is turned so the headlights are on, the cluster and rear lights go out.

I have checked fuses 21 and 22. I have swapped in a working dial.

Thank you in advance for all responses.

John H from Downunder






Cut and paste link:
USERNAME
Use "claim to be" below if you don't want to log in.
PASSWORD
I don't have an account. Sign me up.
CLAIM TO BE
Use only if you don't want to login (post anonymously).
ENTER CAPTCHA CODE
This is required for posting anonymously.
OPTIONS notify by email
Available only to user accounts.
SUBJECT
MODEL/YEAR
MESSAGE

DICTIONARY
LABEL(S) +
IMAGE URL *
[IMAGE LIBRARY (UPLOAD/SELECT)]

* = Field is optional.

+ = Enter space delimited labels for this post. An example entry: 240 muffler

Users marked in green are currently online.

©Jarrod Stenberg 1997-2016. All material except where indicated.


Brickboard.com is not affiliated with nor sponsored by AB Volvo, Volvo Car Corporation, Volvo Cars of North America, Inc. Brickboard.com is a Volvo owner/enthusiast site, similar to a club, and does not intend to pose as an official Volvo site. The official Volvo site can be found here.

All participants agree to these terms.
Powered by Denizen - Custom Software for Enthusiasts