Quantcast
AWD - V70 2005 N/A, crank but no start

Volvo AWD V70-XC70 Forum

INDEX FOR 7/2019(CURRENT) INDEX FOR 5/2002 V70-XC70 INDEX [<<]  [>>]

 VIEW    REPLY TO THIS MESSAGE    PRINT   SAVE   A    A 

V70 2005 N/A, crank but no start V70-XC70

Hey guys,

Back from a 4 months trip, my V70 2005 non turbo will crank but not start.
I own this car for several years but I never had that no start problem before, it's the 1st time. This car has been a fairly reliable so far. I used to own several 850s and S70 in the past and I was able to troubleshoot most problems easily but I'm a lot less familiar with this model and don't know much of it.

The only thing I did is to spray some starting fluid into the intake hose, the engine started a bit but failed to continue running meaning that the ignition system, i,e: plugs, coil packs are OK. I've sprayed a second time, same thing.

Does someone knows where to start my troubleshooting?

Thanks a bunch
--
Dennis






THREADED THREADED EXPANDED FLAT PRINT ALL
MESSAGES IN THIS THREAD

New V70 2005 N/A, crank but no start [V70-XC70]
posted by  Dennis 850GLT  on Mon Apr 22 11:37 CST 2019 >

Cut and paste link:

<< < > >>


Users marked in green are currently online.

©Jarrod Stenberg 1997-2016. All material except where indicated.


Brickboard.com is not affiliated with nor sponsored by AB Volvo, Volvo Car Corporation, Volvo Cars of North America, Inc. Brickboard.com is a Volvo owner/enthusiast site, similar to a club, and does not intend to pose as an official Volvo site. The official Volvo site can be found here.

All participants agree to these terms.
Powered by Denizen - Custom Software for Enthusiasts