Quantcast
AWD - all electrics died... car still ran 03 XC70

Volvo AWD V70-XC70 Forum

INDEX FOR 9/2019(CURRENT) INDEX FOR 4/2010 V70-XC70 INDEX [<<]  [>>]

 VIEW    REPLY TO THIS MESSAGE    PRINT   SAVE   A    A 

all electrics died... car still ran 03 XC70 V70-XC70

Am here seeking advice where to look first or second. 2003 XC70 drove to the store car ran great. Came out started it and the radio went off,air con stopped, lights locks windows all no go. many warning lights. It ran so I drove it home but it didn't have a lot of power. Had been running great since I changed some relays and the alternator. The battery had been fully discharged a number of times before I put in the new alternator. (I suspect there was a phantom draw from voltage regulator.) Thanks a lot for any advice or links. I sincerely appreciate it.






THREADED THREADED EXPANDED FLAT PRINT ALL
MESSAGES IN THIS THREAD

New all electrics died... car still ran 03 XC70 [V70-XC70]
posted by  Kraig  on Sat Jun 8 20:27 CST 2019 >

Cut and paste link:

<< < > >>


Users marked in green are currently online.

©Jarrod Stenberg 1997-2016. All material except where indicated.


Brickboard.com is not affiliated with nor sponsored by AB Volvo, Volvo Car Corporation, Volvo Cars of North America, Inc. Brickboard.com is a Volvo owner/enthusiast site, similar to a club, and does not intend to pose as an official Volvo site. The official Volvo site can be found here.

All participants agree to these terms.
Powered by Denizen - Custom Software for Enthusiasts